Citrix degraded Performance
Incident Report for QHR Technologies Status Page
Resolved
We recently resolved an issue that was impacting our services. All functionality has
been fully restored. Need to report an issue? Please contact us at 1.866.729.8889
Posted Jul 21, 2023 - 10:03 EDT
Update
We are investigating degraded performance issues that are impacting aspects of our
services. Thank you for your continued patience as we work to resolve this. Please check the
Status Page for the latest updates.
Posted Jul 21, 2023 - 09:00 EDT
Update
We are investigating degraded performance issues that are impacting aspects of our
services. Thank you for your patience as we work to resolve this. Please check the
Status Page for the latest updates.
Posted Jul 21, 2023 - 08:00 EDT
Investigating
We are investigating degraded performance issues that are impacting aspects of our
services. Please check the status page for the latest updates.
Posted Jul 21, 2023 - 06:50 EDT
This incident affected: Citrix.