Unable to Launch Accuro

Incident Report for QHR Technologies Status Page

Resolved

We have resolved this issue.

Need to report an issue? Please contact our Client Services line at 1-866-729-8889.
Posted May 19, 2026 - 16:30 EDT

Monitoring

We have implemented an update and are monitoring the results.
Posted May 19, 2026 - 15:00 EDT

Identified

We have identified the issue preventing some users from successfully logging in and we are implementing an update.
Posted May 19, 2026 - 14:00 EDT

Investigating

We are currently investigating an issue that is affecting some users when trying to log into Accuro.
Posted May 19, 2026 - 12:30 EDT
This incident affected: Accuro.