Accuro Users Disconnected or Unable to Launch

Incident Report for QHR Technologies Status Page

Resolved

We have resolved this issue. Please continue to attempt to re-launch Accuro if connectivity issues persist.

Need to report an issue? Please contact our Client Services line at 1-866-729-8889.
Posted Oct 03, 2025 - 13:38 EDT

Monitoring

Please be advised some users and clinic may have experienced a brief outage of Accuro. You may need to re-start your Accuro session. We will continue to monitor.
Posted Oct 03, 2025 - 13:32 EDT

Investigating

We are currently investigating this issue.
Posted Oct 03, 2025 - 13:27 EDT
This incident affected: Accuro.