We have resolved this issue. Please continue to attempt to re-launch Accuro if connectivity issues persist.
Need to report an issue? Please contact our Client Services line at 1-866-729-8889.
Posted Sep 11, 2025 - 13:02 EDT
Monitoring
We have implemented a fix and are monitoring the results. Please attempt to re-launch Accuro at this time. You may still experience some intermittent connectivity issues.
Posted Sep 11, 2025 - 12:38 EDT
Update
We are continuing to work on a fix for this issue.
Please note that this is also affecting our platform integrations such as PrescribeIT, Medeo and Freedom.
Posted Sep 11, 2025 - 12:20 EDT
Identified
We have identified the issue and are working on a fix. Thank you for your patience.
Posted Sep 11, 2025 - 12:07 EDT
Update
We are continuing to investigate this issue.
Posted Sep 11, 2025 - 12:04 EDT
Update
We are continuing to investigate this issue.
Due to the ongoing infrastructure issue the performance of the AccuroAPI is currently being impacted marginally.
Thank you for your patience.
Posted Sep 11, 2025 - 11:55 EDT
Investigating
We are currently investigating an issue with our infrastructure that is affecting Accuro launching.
Posted Sep 11, 2025 - 11:30 EDT
This incident affected: Accuro, Medeo, Citrix, FreedomRx, Platform Integrations, and Accuro Admin Centre.