Accuro API Outage

Incident Report for QHR Technologies Status Page

Resolved

We have resolved this issue.

Need to report an issue? Please contact our Client Services line at 1-866-729-8889.
Posted Sep 02, 2025 - 10:27 EDT

Monitoring

We have implemented a fix and are monitoring the results. Thank you for your patience.
Posted Sep 02, 2025 - 10:02 EDT

Identified

We have identified the issue and are implementing a fix.
Posted Sep 02, 2025 - 10:00 EDT

Investigating

We are investigating an issue that is affecting Accuro API connections. This includes services such as the Accuro Admin Centre, Ocean etc.
Posted Sep 02, 2025 - 09:30 EDT
This incident affected: Platform Integrations and Accuro Admin Centre.