We are investigating an issue that is affecting Accuro API connections. This includes services such as the Accuro Admin Centre, Ocean etc.

Incident Report for QHR Technologies Status Page

Resolved

This incident has been resolved.
Posted Sep 04, 2025 - 08:14 EDT

Investigating

We are currently investigating this issue.
Posted Sep 04, 2025 - 08:02 EDT
This incident affected: Platform Integrations and Accuro Admin Centre.