Unite Faxing Degraded Performance

Incident Report for Accuro Status Page

Resolved

Unite has advised their systems are now fully operational.

Need to report an issue? Please contact client services at accuro@qhrtech.com or 1-866-729-8889
Posted Aug 12, 2026 - 10:30 EDT

Investigating

We have received notice from Unite Faxing that their carrier is experiencing an outage that is causing degraded performance to their systems.

For additional information please refer to their status page at https://status.unite.ca
Posted Aug 12, 2026 - 09:32 EDT
This incident affected: Vendor Outages (Non-QHR).