Web Accuro and Ace may be affected by a outage
Incident Report for QHR Technologies Status Page
Resolved
This incident has been resolved.
Posted Sep 24, 2024 - 14:19 EDT
Identified
The issue has been identified and a fix is being implemented
Posted Sep 24, 2024 - 13:22 EDT
Update
We are continuing to investigate this issue - issue will affect ACE, Faxing, Labs, and Cliniconex. Please keep a eye on the status page for further issues.
Posted Sep 24, 2024 - 12:36 EDT
Investigating
We are currently investigating this issue - please keep eye on status page for further updates.
Posted Sep 24, 2024 - 12:20 EDT
This incident affected: Accuro and Platform Integrations.