Unite Faxing - Degraded Fax Performance

Incident Report for QHR Technologies Status Page

Resolved

We have received confirmation that this issue has been resolved.

Need to report an issue? Please contact our Client Services line at 1-866-729-8889.
Posted May 26, 2026 - 08:04 EDT

Update

Unite has confirmed there is still an issue impacting their system. There is no estimated time of resolution. We will update this incident once the issue is resolved or more information becomes available.

Please continue to monitor Unite's status page - https://unite.ca/networkstatus/
Posted May 25, 2026 - 20:11 EDT

Update

Unite has confirmed there is still an issue impacting their system. There is no estimated time of resolution. We will update this incident once the issue is resolved or more information becomes available.

Please continue to monitor Unite's status page - https://unite.ca/networkstatus/
Posted May 25, 2026 - 17:29 EDT

Update

Unite has confirmed there is still an issue impacting their system. There is no estimated time of resolution. We will update this incident once the issue is resolved or more information becomes available.

Please continue to monitor Unite's status page - https://unite.ca/networkstatus/
Posted May 25, 2026 - 14:00 EDT

Investigating

Unite Faxing are investigating an issue that is causing degraded performance for some users. This is affecting both inbound and outbound faxing.

We will update when more information is available. Users can also monitor on Unite's status page - https://unite.ca/networkstatus/
Posted May 25, 2026 - 12:00 EDT
This incident affected: Vendor Outages (Non-QHR).