ON - Users unable to download HRM reports
Incident Report for QHR Technologies Status Page
Resolved
We have resolved this issue.

Need to report an issue? Please contact us at 1-866-729-8889.
Posted Sep 09, 2024 - 17:59 EDT
Investigating
We are investigating an issue that is causing some Ontario clients are unable to download HRM reports from OntarioMD and are receiving "Connection timed out" errors.
Posted Sep 09, 2024 - 17:25 EDT
This incident affected: Platform Integrations.