User may experience issues launching Accuro
Incident Report for QHR Technologies Status Page
Resolved
This incident has been resolved.

Need to report an issue? Please contact our Client Services line at 1-866-729-8889.
Posted Jan 15, 2025 - 10:08 EST
Identified
The issue has been identified and we are working on a fix - please keep a eye on the status page for the next update.
Posted Jan 15, 2025 - 09:16 EST
This incident affected: Accuro.