Accuro Connectivity - Degraded Performance

Incident Report for Accuro Status Page

Resolved

This incident has been resolved.

Need to report an issue? Please contact our Client Services line at 1-866-729-8889.
Posted Aug 20, 2026 - 12:45 EDT

Monitoring

Accuro connectivity issues have been resolved and Accuro is working as expected. We are continuing to monitor.
Posted Aug 20, 2026 - 12:35 EDT

Investigating

We are investigating an issue that is affecting some users connectivity when using Accuro. Affected users are seeing "Citrix Disconnected" messages while losing connectivity to their Accuro session(s).
Posted Aug 20, 2026 - 11:45 EDT
This incident affected: Accuro.