Accuro Slowness

Incident Report for QHR Technologies Status Page

Resolved

We have resolved this issue. Thank you for your patience.

Need to report an issue? Please contact our Client Services line at 1-866-729-8889.
Posted May 12, 2025 - 16:23 EDT

Identified

We have identified the issue and are implementing a fix.
Posted May 12, 2025 - 16:00 EDT

Update

We are continuing to investigate this issue. Thank you for your patience.
Posted May 12, 2025 - 15:30 EDT

Investigating

We are currently investigating an issue that may be causing performance or slowness issues for some users in Accuro.
Posted May 12, 2025 - 12:30 EDT
This incident affected: Accuro.