Users may be experiencing unable to log in or unable to access Accuro

Incident Report for QHR Technologies Status Page

Resolved

We have resolved this issue. Need to report an issue? Please contact our Client Services line at 1-866-729-8889.
Posted May 07, 2025 - 00:37 EDT

Update

We are currently still investigating this issue - Faxes, scanning, and labs should be operational at this time.

One server has restored, but there may be some users still unable to log in; we are actively investigating.
Posted May 06, 2025 - 20:13 EDT

Update

We are currently still investigating this issue - Faxes, scanning, and labs should be operational at this time.

One server has restored, but there may be some users still unable to log in; we are actively investigating.
Posted May 06, 2025 - 18:14 EDT

Update

We are currently still investigating this issue - Faxes, scanning, and labs should be operational at this time.

One server has restored, but there may be some users still unable to log in; we are actively investigating.
Posted May 06, 2025 - 16:25 EDT

Update

We are currently still investigating this issue - Faxes, scanning, and labs should be operational at this time.

One server has restored, but there may be some users still unable to log in; we are actively investigating.
Posted May 06, 2025 - 15:25 EDT

Update

We are currently still investigating this issue - Faxes, scanning, and labs should be operational at this time.

One server has restored, but there may be some users still unable to log in; we are actively investigating.
Posted May 06, 2025 - 14:36 EDT

Update

We are currently investigating the issue - clients who can log in may be experiencing issues with faxes, scanning and labs.
Posted May 06, 2025 - 13:47 EDT

Investigating

We are currently investigating this issue.
Posted May 06, 2025 - 13:27 EDT

Identified

We are currently investigating this issue.
Posted May 06, 2025 - 13:26 EDT

Update

We are continuing to investigate this issue.
Posted May 06, 2025 - 12:47 EDT

Update

We are currently investigating this issue, please keep a eye on status page for most up to date information.
Posted May 06, 2025 - 12:40 EDT

Investigating

We are currently investigating this issue.
Posted May 06, 2025 - 12:19 EDT
This incident affected: Accuro.