Unite Faxing - Degraded Performance

Incident Report for QHR Technologies Status Page

Resolved

This issue has been resolved.

Need to report an issue? Please contact our Client Services line at 1-866-729-8889.
Posted May 28, 2026 - 11:30 EDT

Monitoring

Inbound and outbound faxing via Unite is now working as expected and we are continuing to monitor.
Posted May 28, 2026 - 08:00 EDT

Update

We are continuing to investigate this issue.
Posted May 28, 2026 - 07:00 EDT

Update

We are continuing to investigate this issue.
Posted May 27, 2026 - 20:27 EDT

Update

We are continuing to investigate this issue.
Posted May 27, 2026 - 19:28 EDT

Update

This issue is still being investigated. We will share any updates we receive.
Posted May 27, 2026 - 14:00 EDT

Update

We have been advised that Unite has temporarily limited sending and receiving faxes as they are receiving a high number of requests. We are working together with Unite and will update when more information is available.

Users can also monitor on Unite's status page - https://status.unite.ca/
Posted May 27, 2026 - 11:00 EDT

Investigating

We have identified an issue with downloading inbound faxes from Unite and we are working with them to resolve the issue. We will update when more information is available.

Users can also monitor on Unite's status page - https://status.unite.ca/
Posted May 27, 2026 - 08:00 EDT
This incident affected: Vendor Outages (Non-QHR).