Invalid Client Secret Provided Error When Attempting To Open Documents

Incident Report for QHR Technologies Status Page

Resolved

This incident has been resolved. Please restart your Accuro to gain access to documents again.

Need to report an issue? Please contact our Client Services line at 1-866-729-8889.
Posted Jun 19, 2025 - 10:44 EDT

Update

We are continuing to investigate this issue.
Posted Jun 19, 2025 - 09:40 EDT

Investigating

We are currently investigating a issue with documents, please keep eye on status page for most recent updates
Posted Jun 19, 2025 - 09:00 EDT
This incident affected: Accuro.