Medeo/Engage functions currently down - Provider log in, online booking, and Video visits currently affected
Incident Report for QHR Technologies Status Page
Resolved
We have received confirmation that this issue has been resolved. Please note any new online bookings in this time will be delayed but will still arrive.

Need to report an issue? Please contact our Client Services line at 1-866-729-8889.
Posted Jan 08, 2025 - 13:20 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 08, 2025 - 13:16 EST
Update
We are continuing to investigate this issue.
Posted Jan 08, 2025 - 12:53 EST
Investigating
We are currently investigating this issue - please keep eye on status page for most up to date details
Posted Jan 08, 2025 - 12:51 EST
This incident affected: Medeo.