Unite Faxing - Degraded Performance

Incident Report for QHR Technologies Status Page

Resolved

We have received confirmation from Unite that the issue at their primary carrier's datacenter has been resolved and inbound faxing should now be functioning as expected.

Need to report an issue? Please contact our Client Services line at 1-866-729-8889.
Posted May 28, 2026 - 13:45 EDT

Investigating

Unite Fax has confirmed there is an issue with their primary carrier that is currently impacting their system, specifically inbound faxing.

There is no estimated time of resolution. We will update this incident once the issue is resolved or more information becomes available.

Users can also monitor on Unite's status page - https://status.unite.ca/
Posted May 28, 2026 - 13:00 EDT
This incident affected: Vendor Outages (Non-QHR).