Unite Faxing - Degraded Performance

Incident Report for QHR Technologies Status Page

Resolved

We have received confirmation that this issue has been resolved.

Need to report an issue? Please contact our Client Services line at 1-866-729-8889.
Posted Nov 20, 2025 - 12:32 EST

Update

Unite has confirmed there is an issue impacting their system that is causing degraded fax performance for some users.

We will update this incident once the issue is resolved or more information becomes available, Unite users can also monitor for updates on Unite's status page - https://unite.ca/networkstatus/
Posted Nov 20, 2025 - 11:30 EST

Update

Unite has confirmed there is an issue impacting their system that is causing degraded fax performance for some users.

We will update this incident once the issue is resolved or more information becomes available, Unite users can also monitor for updates on Unite's status page - https://unite.ca/networkstatus/
Posted Nov 19, 2025 - 19:49 EST

Update

Unite has confirmed there is an issue impacting their system that is causing degraded fax performance for some users.

We will update this incident once the issue is resolved or more information becomes available, Unite users can also monitor for updates on Unite's status page - https://unite.ca/networkstatus/
Posted Nov 19, 2025 - 18:10 EST

Update

Unite has confirmed there is an issue impacting their system that is causing degraded fax performance for some users.

We will update this incident once the issue is resolved or more information becomes available, Unite users can also monitor for updates on Unite's status page - https://unite.ca/networkstatus/
Posted Nov 19, 2025 - 15:15 EST

Investigating

Unite has confirmed there is an issue impacting their system that is causing degraded fax performance for some users.

We will update this incident once the issue is resolved or more information becomes available, Unite users can also monitor for updates on Unite's status page - https://unite.ca/networkstatus/
Posted Nov 19, 2025 - 12:23 EST
This incident affected: Vendor Outages (Non-QHR).