Unable to access Accuro or Medeo

Incident Report for Accuro Status Page

Resolved

This has been resolved - thank you for your patience.

Need to report an issue? Please contact our Client Services line at 1-866-729-8889.
Posted Jun 05, 2026 - 14:19 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 05, 2026 - 14:08 EDT

Identified

We are working on restarting the network connections on the affected virtual desktops/servers, and after doing that, the monitoring system is no longer reporting any issues on that server.
Posted Jun 05, 2026 - 14:06 EDT

Update

Please be aware we are investigating a issue that will affect some current Accuro sessions and Medeo.
We will update the status page with the most up to date information as it becomes available.
Posted Jun 05, 2026 - 13:00 EDT

Investigating

We are currently investigating this issue.
Posted Jun 05, 2026 - 12:48 EDT
This incident affected: Accuro and Medeo.