Can’t Access Accuro
Incident Report for QHR Technologies Status Page
Resolved
The CloudStrike issue has been resolved. We are continuing to monitor as a precaution.

Need to report an issue? Please contact us at 1.866.729.8889 or alternatively via email at support@qhrtech.com.
Posted Jul 19, 2024 - 10:21 EDT
Update
Most Clients should now be able to log into Accuro, However some Clients may still find Accuro in a degraded state, we are continuing to work on resolving the issues for these clients.
Posted Jul 19, 2024 - 08:58 EDT
Identified
The latest update to CrowdStrike may be impacting our servers and causing login issues for some clients. This is a large scale issue that impacted CloudStrike customers worldwide. We are working to resolve it as soon as possible. We will post more updates as they become available.

CrowdStrike provides cloud workload and endpoint security, threat intelligence, and cyberattack response services.
Posted Jul 19, 2024 - 02:39 EDT
This incident affected: Accuro.