Can't Launch Accuro
Incident Report for QHR Technologies Status Page
Resolved
We have resolved this issue.

Need to report an issue? Please contact us at 1.866.729.8889 or alternatively via email at support@qhrtech.com.
Posted Jul 19, 2024 - 18:03 EDT
Monitoring
We have identified the causes of the issues launching Accuro. We have implemented a fix and are monitoring the results.
Posted Jul 19, 2024 - 14:42 EDT
Investigating
We are investigating reports that some users are still experiencing issues launching Accuro following this morning's outage.
Posted Jul 19, 2024 - 13:41 EDT
This incident affected: Accuro and Citrix.