Unite- Ontario / Alberta / BC Accuro Fax

Incident Report for QHR Technologies Status Page

Resolved

This issue is resolved - Faxes are converting and sending properly. There is a substantial back log but it is processing in a normal and timely manner.
Posted Dec 05, 2025 - 16:54 EST

Investigating

Unite has confirmed there is an issue with the conversion process on their fax server.

Please see the Unite Status page for further updates https://unite.ca/networkstatus/
Posted Dec 05, 2025 - 11:24 EST
This incident affected: Vendor Outages (Non-QHR).