Slowness in Accuro

Incident Report for QHR Technologies Status Page

Resolved

This issue has been resolved
Posted Jun 19, 2025 - 13:22 EDT

Update

We are continuing to investigate this issue.
Posted Jun 19, 2025 - 12:31 EDT

Investigating

We are investigating an issue that could be causing slowness for some users in Accuro.
Posted Jun 19, 2025 - 12:30 EDT
This incident affected: Accuro.