Tricerat Simplify Printing and ScrewDriver EndPoint Errors

Incident Report for QHR Technologies Status Page

Resolved

We have resolved this issue. Need to report an issue? Please contact our Client Services line at 1-866-729-8889.
Posted May 05, 2025 - 15:43 EDT

Identified

We have identified the issue affecting Tricerat and Screwdrivers licenses and we are implementing an update.
Posted May 05, 2025 - 15:23 EDT

Investigating

We are currently investigating reports of users receiving one following errors in regards to Tricerat/Screwdrivers printing:

Product: Simplify Printing/Product: Screwdrivers Endpoint :"Unable to acquire product license. Please contact your administrator for assistance"

If this is affecting your ability to print out of Accuro, please contact Client Services at 1-866-729-889 and select option 2 for Tech.
Posted May 05, 2025 - 12:45 EDT
This incident affected: Platform Integrations.