OLIS / Econsult Limited Access
Incident Report for QHR Technologies Status Page
Resolved
We have received confirmation that this issue has been resolved. Need to report an issue? Please contact our Client Services line at 1-866-729-8889.
Posted Nov 14, 2024 - 14:23 EST
Update
This issue is still being investigated by OMD. We will share any updates we receive.
Posted Nov 14, 2024 - 14:19 EST
Identified
We have been advised that OMD is experiencing an issue with OneID logins affecting multiple services. We will update this incident once the issue is resolved or more information becomes available.
Posted Nov 14, 2024 - 12:09 EST
This incident affected: Vendor Outages (Non-QHR).