ON Excelleris Outage - There was an error processing Excelleris lab results

Incident Report for Accuro Status Page

Resolved

We have received confirmation from Excelleris that lab processing functionality has been restored and the outage is resolved.

Need to report an issue?
Contact Accuro Client Services at accuro@qhrtech.com or 1-866-729-8889
Posted Aug 07, 2026 - 14:55 EDT

Update

We are continuing to monitor for any further issues.
Posted Aug 07, 2026 - 10:48 EDT

Update

Excelleris labs processing appears to now be working as intended. We will continue to monitor for additional information from Excelleris.

Please contact Excelleris/Rover Support directly for the latest updates or assistance.
Email: excelleris-support@lifelabs.com
Phone: 1-866-728-4777
Posted Aug 06, 2026 - 20:16 EDT

Monitoring

Excelleris labs processing appears to now be working as intended. We will continue to monitor for additional information from Excelleris.

Please contact Excelleris/Rover Support directly for the latest updates or assistance.
Email: excelleris-support@lifelabs.com
Phone: 1-866-728-4777
Posted Aug 06, 2026 - 08:32 EDT

Update

We have confirmed the Excelleris outage is still ongoing. Excelleris is continuing to work on resolving the issue.

Please contact Excelleris/Rover Support directly for the latest updates or assistance.
Email: excelleris-support@lifelabs.com
Phone: 1-866-728-4777
Posted Aug 05, 2026 - 20:21 EDT

Update

We have confirmed the Excelleris outage is still ongoing. Excelleris is continuing to work on resolving the issue.

Please contact Excelleris/Rover Support directly for the latest updates or assistance.
Email: excelleris-support@lifelabs.com
Phone: 1-866-728-4777
Posted Aug 05, 2026 - 08:41 EDT

Update

We are currently aware of a confirmed outage affecting Excelleris for Ontario clients. This issue may result in the following error message:

"There was an error processing Excelleris lab results. Contact QHR Technologies for assistance."

The Excelleris team is actively working to restore service as quickly as possible.

Please contact Excelleris/Rover Support directly for the latest updates or assistance.
Email: excelleris-support@lifelabs.com
Phone: 1-866-728-4777

We will post updates as they are made available to us. Thank you for your patience.
Posted Aug 04, 2026 - 19:34 EDT

Identified

We are currently aware of a confirmed outage affecting Excelleris for Ontario clients. This issue may result in the following error message:

"There was an error processing Excelleris lab results. Contact QHR Technologies for assistance."

The Excelleris team is actively working to restore service as quickly as possible.

Please contact Excelleris/Rover Support directly for the latest updates or assistance.
Email: excelleris-support@lifelabs.com
Phone: 1-866-728-4777

We will post updates as they are made available to us. Thank you for your patience.
Posted Aug 04, 2026 - 08:00 EDT
This incident affected: Vendor Outages (Non-QHR).