Opening Document from the Virtual Chart

Incident Report for QHR Technologies Status Page

Resolved

This issue has been resolved.

Need to report an issue? Please contact our Client Services line at 1-866-729-8889.
Posted Mar 19, 2025 - 11:09 EDT

Identified

This issue has been identified, we have rolled back the version of Accuro experiencing the issue. Please restart Accuro and you should be able to access.
Posted Mar 19, 2025 - 10:43 EDT

Investigating

We are investigating an issue that is impacting some users ability to Open Documents in the Virtual Chart.
Posted Mar 19, 2025 - 10:10 EDT
This incident affected: Accuro.