Alberta - Unable to Create Notes from "Electronic Drawer" or "New Copies", or view Labs in Encounter Notes tab

Incident Report for QHR Technologies Status Page

Resolved

We have resolved this issue. Users will need to sign out of their current Accuro session and launch a new session for the fix to take place.

Need to report an issue? Please contact our Client Services line at 1-866-729-8889.
Posted Jun 11, 2025 - 13:22 EDT

Identified

We have identified the issue and are working on a fix. Thank you for your patience.
Posted Jun 11, 2025 - 12:40 EDT

Investigating

We are currently investigating an issue affecting some user's ability to create notes from the Electronic Drawer or "New Copies", and view Labs in the Encounter Notes tab.
Posted Jun 11, 2025 - 11:00 EDT
This incident affected: Accuro.