We have confirmed with the Ministry of Health Ontario that the MCEDT outage is resolved. Users may resume claim submission and health card validation.
Need to report an issue? Please contact us at 1-866-729-8889 or accuro@qhrtech.com
Posted Aug 14, 2026 - 15:34 EDT
Monitoring
OPS BPS Secure/MCEDT have advised that the outage has been resolved and their services are restored. We will continue to monitor for any further issues. At this time, users may resume submissions/health card validations.
Posted Aug 14, 2026 - 15:08 EDT
Update
The Ministry of Health's incident support team advised they are still working towards a resolution. Please continue to monitor the OPS BPS Secure webpage and contact the ministry directly at 1-800-262-6524 for additional information.
Posted Aug 14, 2026 - 13:48 EDT
Identified
We have confirmed a province-wide outage with the Ontario Ministry of Health, affecting web submissions and health card validations through the MCEDT/OPS BPS Secure system.
Clients will receive the following error in Accuro when attempting submission or health card validation: There was an error initializing the HCV web services port. Connection timed out.
Please continue to monitor the OPS BPS Secure webpage and contact the ministry directly at 1-800-262-6524 for additional information.