FreedomRx Outage
Incident Report for QHR Technologies Status Page
Resolved
We recently resolved an issue that was impacting our services. All functionality has been fully restored. Need to report an issue? Please contact us at 1.866.729.8889 or support@qhrtech.com.
Posted Jan 25, 2022 - 20:31 EST
Update
We are still in the process of resolving this issue. The next update will be at 8:15pm EST
Posted Jan 25, 2022 - 18:13 EST
Update
We are continuing to work on a fix for this issue. The next update will be at 6:00pm EST
Posted Jan 25, 2022 - 17:01 EST
Update
We are continuing to work on this. Thank you for your patience. The next update will be at 5:00pm EST
Posted Jan 25, 2022 - 16:23 EST
Update
We are continuing to investigate this issue.
Posted Jan 25, 2022 - 15:44 EST
Investigating
We are investigating reports of an issue that is preventing access to our services. Thank you for your patience as we look into this. Please continue to check the status page for the latest updates.
Posted Jan 25, 2022 - 15:21 EST
This incident affected: FreedomRx.