Clinics may be encountering issues with Cliniconex appointment reminders. We have identified the problem and will be restarting a server. Please note that this may cause an interruption, and clinics may need to start a new session during this time.

Incident Report for QHR Technologies Status Page

Resolved

This issue has been resolved.

Need to report an issue? Please contact our Client Services line at 1-866-729-8889.
Posted Mar 28, 2025 - 13:58 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 28, 2025 - 13:18 EDT

Identified

This has been identified and we are currently work on a fix.

Once refreshed clients will be on the legacy version of Accuro and will no longer be able to use the new UI version.
Posted Mar 28, 2025 - 12:51 EDT
This incident affected: Accuro.