Microsoft Office 365 Email Service Outage

Incident Report for QHR Technologies Status Page

Resolved

This incident has been resolved.
Posted Jan 23, 2026 - 08:45 EST

Identified

We are currently aware of an issue where Accuro self-service password reset and new user activation emails may be delayed for Clinics using Microsoft Office 365 (M365) as their email service provider.

This appears to be related to a widespread Microsoft Office 365 service disruption and is outside of QHR's direct control. Accuro remains operational; however, email delivery from Accuro teams to affected email providers may be delayed.

Workarounds:

If urgent access is required, Clinic Administrators can complete password resets or user activations directly through the Accuro Admin Centre.

Where possible, please use alternative communication methods if your organization is currently impacted by the M365 email disruption.

We are continuing to monitor the situation and will provide updates as more information becomes available.

Thank you.
Posted Jan 22, 2026 - 19:23 EST
This incident affected: Vendor Outages (Non-QHR).