Client Services unable to answer calls at moment due to Salesforce outage
Incident Report for QHR Technologies Status Page
Resolved
This has been resolved, please call back into Client Services if we missed you in any way.
Posted Nov 15, 2024 - 08:29 EST
Investigating
We are currently investigating - but at the moment unable to take calls or verify anyone as the software is down.

We will continue to update here and remove status page once its cleared.
Posted Nov 15, 2024 - 08:11 EST