Freedom Outage
Incident Report for QHR Technologies Status Page
Resolved
This incident has been resolved.
Posted Apr 23, 2024 - 12:04 EDT
Investigating
We are currently investigating an issue that is impacting our Freedom services.

Accounts may not be able to access the application or could experience major delays in sending and receiving e-prescriptions and messages.
Posted Apr 22, 2024 - 15:00 EDT
This incident affected: Accuro and FreedomRx.