Medeo Patients being unsubscribed from Medeo emails
Incident Report for QHR Technologies Status Page
Resolved
This incident has been resolved.
Posted Apr 19, 2024 - 13:01 EDT
Update
We are continuing to investigate this issue - patients may be experiencing issues with receiving messages. Messages will still be seen in patient medeo accounts.

We will not continue to update the status page every 2 hours - we will update again once we have more information.

Patients can contact QHR via live chat or webform and agents will assist them in receiving their emails https://qhrtech.my.site.com/patient/s/
Posted Apr 18, 2024 - 16:58 EDT
Update
We are continuing to investigate this issue - patients may be experiencing issues with receiving messages. Messages will still be seen in patient medeo accounts.

Patients can contact QHR via live chat or webform and agents will assist them in receiving their emails https://qhrtech.my.site.com/patient/s/
Posted Apr 18, 2024 - 16:03 EDT
Update
We are continuing to investigate this issue - patients may be experiencing issues with receiving messages. Messages will still be seen in patient medeo accounts.

Patients can contact QHR via live chat or webform and agents will assist them in receiving their emails https://qhrtech.my.site.com/patient/s/
Posted Apr 18, 2024 - 14:39 EDT
Update
We are continuing to investigate this issue.
Posted Apr 18, 2024 - 13:18 EDT
Update
We are continuing to investigate this issue.
Posted Apr 18, 2024 - 12:24 EDT
Update
We are continuing to investigate this issue.
Posted Apr 18, 2024 - 10:30 EDT
Investigating
We are currently investigating this issue. When a Medeo Patient attempts to reset their password to many times - they are automatically being placed on a unsubscribe list. This will cause them not to receive any further communication from clinics.

Medeo patients are able to live chat with our agent or send a web form - https://qhrtech.my.site.com/patient/s/ - and our agents are able to remove them from the list.
Posted Apr 18, 2024 - 09:19 EDT
This incident affected: Medeo.