Some Lab Results not Opening

Incident Report for QHR Technologies Status Page

Resolved

While we implement a fix for this issue, please continue to launch Accuro via Accuro EMR Legacy.

Need to report an issue? Please contact our Client Services line at 1-866-729-8889.
Posted Mar 27, 2025 - 15:43 EDT

Identified

We have identified the issue and are implementing a fix.
Posted Mar 27, 2025 - 13:10 EDT

Investigating

We are investigating an issue that is affecting the ability of some clients to open Lab Results. Please utilize the Legacy Accuro option when launching.
Posted Mar 27, 2025 - 09:59 EDT
This incident affected: Accuro.