Accuro Crashing and Unable To Load

Incident Report for QHR Technologies Status Page

Resolved

We have resolved this issue. Need to report an issue? Please contact our Client Services line at 1-866-729-8889.
Posted Jul 15, 2025 - 14:37 EDT

Update

We are continuing to monitor. Thank you for your patience.
Posted Jul 15, 2025 - 13:12 EDT

Update

We are continuing to investigate reports of users still unable to launch Accuro and are monitoring closely.
Posted Jul 15, 2025 - 12:41 EDT

Update

We are continuing to monitor the issue. Please be advised that it may take multiple attempts to successfully launch Accuro.
Posted Jul 15, 2025 - 12:26 EDT

Monitoring

We have implemented a fix and are monitoring the results. Users may still experience slowness when attempting to launch.
Posted Jul 15, 2025 - 12:07 EDT

Update

We are continuing to investigate this issue. Thank you for your patience.
Posted Jul 15, 2025 - 12:00 EDT

Investigating

We are investigating an issue that is causing Accuro to crash and subsequent sessions to not launch.
Posted Jul 15, 2025 - 11:40 EDT
This incident affected: Accuro.