Authentication service for Accuro API

Incident Report for QHR Technologies Status Page

Resolved

We have received confirmation that this issue has been resolved.

Need to report an issue? Please contact our Client Services line at 1-866-729-8889.
Posted May 15, 2026 - 14:20 EDT

Update

We are continuing to monitor for any further issues.
Posted May 15, 2026 - 13:11 EDT

Monitoring

We had issue with the Authentication server for Accuro API. The server has been restarted and Accuro API should be available to the clients now.

We will continue to monitor this
Posted May 15, 2026 - 13:11 EDT
This incident affected: Accuro and Platform Integrations.