Accuro web down for some users - faxes, scanning, and labs may be affected

Incident Report for QHR Technologies Status Page

Resolved

We have resolved this issue. Need to report an issue? Please contact our Client Services line at 1-866-729-8889.
Posted May 07, 2025 - 15:01 EDT

Update

We are continuing to monitor for any further issues.
Posted May 07, 2025 - 15:00 EDT

Monitoring

We have implemented a fix and are monitoring your results. Thank you for your patience.
Posted May 07, 2025 - 14:43 EDT

Update

We are continuing to investigate this issue.
Posted May 07, 2025 - 11:10 EDT

Investigating

We are currently investigating this issue.
Posted May 07, 2025 - 09:58 EDT
This incident affected: Accuro.