HRM Error: Error connecting to SFTP server. connection timed out
Incident Report for QHR Technologies Status Page
Resolved
We have resolved this issue.
Posted Oct 01, 2024 - 13:53 EDT
Update
We are continuing to investigate this issue.

The next update will be at 2:00pm EDT.
Posted Oct 01, 2024 - 13:01 EDT
Investigating
We are investigating an issue that is impacting HRM Connections with Accuro and displaying the error: Error connecting to SFTP server. Connection timed out.

We will provide an update at 1:00pm EDT.
Posted Oct 01, 2024 - 12:25 EDT
This incident affected: Platform Integrations.