Unite Faxing - Intermittent Faxing Disruption

Incident Report for QHR Technologies Status Page

Resolved

We have received confirmation that this issue has been resolved; however, as per Unite, some faxes may take longer to process as the system works through backlog.

Need to report an issue? Please contact our Client Services line at 1-866-729-8889.
Posted Apr 01, 2026 - 13:45 EDT

Investigating

Unite has confirmed they are investigating a connection issue that is causing intermittent fax disruptions for some users.

For more information, please see Unite's status page - https://unite.ca/networkstatus/
Posted Apr 01, 2026 - 13:00 EDT
This incident affected: Vendor Outages (Non-QHR).