Accuro Slowness
Incident Report for QHR Technologies Status Page
Resolved
We have resolved this issue. Thank you for your patience.

Need to report an issue? Please contact our Client Services line at 1-866-729-8889.
Posted Dec 05, 2024 - 16:58 EST
Monitoring
We have identified the issue, implemented a fix and are monitoring the results.
Posted Dec 05, 2024 - 15:46 EST
Investigating
We are currently investigating an issue that may be causing performance or slowness issues for some users in Accuro.
Posted Dec 05, 2024 - 15:13 EST
This incident affected: Accuro.