Unite Accuro Faxing - Degraded Service

Incident Report for QHR Technologies Status Page

Resolved

This incident has been resolved.
Posted Mar 28, 2025 - 10:32 EDT

Identified

Unite has confirmed there is an issue impacting their system with Accuro faxes. There is no estimated time of resolution. We will update this incident once the issue is resolved or more information becomes available.
Posted Mar 28, 2025 - 09:47 EDT
This incident affected: Vendor Outages (Non-QHR).