GoSecure Outage - Ontario
Incident Report for QHR Technologies Status Page
Resolved
This incident has been resolved.
Posted Sep 20, 2024 - 11:56 EDT
Update
We are continuing to monitor for any further issues.
Posted Sep 20, 2024 - 08:32 EDT
Monitoring
We have identified that the GoSecure website in Ontario has been affected by technical issues which will affect your ability to validate health cards and submit claims. Please continue to check our status page for updates.
Posted Sep 20, 2024 - 08:32 EDT
This incident affected: Vendor Outages (Non-QHR).