Please be advised that we are investigating reports of disrupted service in Accuro Chat for users outside of Ontario

Incident Report for QHR Technologies Status Page

Resolved

This incident has been resolved.
Posted Sep 12, 2025 - 08:53 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 12, 2025 - 08:45 EDT

Investigating

We are currently investigating this issue, please keep your eye on the status page for the most recent updates.
Posted Sep 12, 2025 - 08:36 EDT
This incident affected: Accuro.