Unite - Atlantic, Saskatchewan, Manitoba sites- Fax Manager Status Incorrect

Incident Report for QHR Technologies Status Page

Update

Our development teams are working with Unite developers to determine the cause.

Please see Unite Status page for further updates-https://unite.ca/networkstatus/
Posted Nov 26, 2025 - 16:29 EST

Update

Our development teams are working with Unite developers to determine the cause.

Please see Unite Status page for further updates-https://unite.ca/networkstatus/
Posted Nov 26, 2025 - 07:18 EST

Update

Our development teams are working with Unite developers to determine the cause.

Please see Unite Status page for further updates-https://unite.ca/networkstatus/
Posted Nov 25, 2025 - 20:00 EST

Update

Our development teams are continuing to investigate this issue.

Please see Unite Status page for further updates-https://unite.ca/networkstatus/
Posted Nov 25, 2025 - 19:24 EST

Investigating

We are experiencing an issue with the fax service where Accuro shows a completed status for sent faxes that have actually failed.

Our development teams are working with Unite developers to determine the cause.

Please see Unite Status page for further updates-https://unite.ca/networkstatus/
Posted Nov 25, 2025 - 12:09 EST
This incident affects: Vendor Outages (Non-QHR).