Unable to Launch Accuro (Nova Scotia)

Incident Report for QHR Technologies Status Page

Resolved

We have resolved this issue. Need to report an issue? Please contact our Client Services line at 1-866-729-8889.
Posted Feb 03, 2025 - 10:07 EST

Monitoring

We have implemented a fix and are monitoring the results.
Posted Jan 31, 2025 - 10:51 EST

Update

We are currently investigating an issue that is affecting a small number of Nova Scotia clinics when logging into Accuro
Posted Jan 31, 2025 - 09:13 EST

Investigating

We are currently investigating an issue that is affecting a small number of clinics when logging into Accuro.
Posted Jan 31, 2025 - 08:56 EST
This incident affected: Accuro.