Need to report an issue? Please contact our Client Services line at 1-866-729-8889.
Posted Dec 03, 2025 - 12:00 EST
Update
The incident from Okta is still ongoing and mitigation efforts are continuing.
If users experience a failed login, we recommend attempting to sign in again. Based on current observations, follow-up login attempts are expected to succeed.
Posted Dec 03, 2025 - 11:51 EST
Monitoring
The incident from Okta is still ongoing and mitigation efforts are continuing.
If users experience a failed login, we recommend attempting to sign in again. Based on current observations, follow-up login attempts are expected to succeed.
Posted Dec 03, 2025 - 10:10 EST
Identified
The Issue has been identified as a issue with OKTA, please see OKTA status page as well as ours for more information.
Please be aware the issue seems intermittent with OKTA - and some users are able to still log in at times.