Accuro Slowness

Incident Report for QHR Technologies Status Page

Identified

We believe this issue was caused by a recently enabled configuration setting. This setting as been turned off and we have an update being released tonight to ensure this is disabled. We will continue to monitor and review in the meantime.
Posted Nov 17, 2025 - 18:27 EST

Update

We are continuing to investigate this issue.
Posted Nov 17, 2025 - 18:02 EST

Update

We are continuing to investigate this issue. Thank you for your patience.
Posted Nov 17, 2025 - 15:44 EST

Update

We are continuing to investigate this issue. Thank you for your patience.
Posted Nov 17, 2025 - 13:45 EST

Update

We are continuing to investigate this issue. Thank you for your patience.
Posted Nov 17, 2025 - 12:30 EST

Investigating

We are currently investigating an issue where some users may be experiencing issues with slowness or performance while using Accuro.
Posted Nov 17, 2025 - 11:59 EST
This incident affects: Accuro.